[openadk] Root password problem

Diez B. Roggisch deets at web.de
Tue Jul 4 10:27:51 CEST 2017


How did you set the password?

I got confused the first time (it *is* documented though!) because I just wrote the new password into the config.

But you need to run

 ./host_*/usr/bin/mkcrypt

to generate the hash. Cleartext won’t work!

Diez


> On 4. Jul 2017, at 10:07, G Z <gtfo at inbox.eu> wrote:
> 
> Hello,
> I'm trying to login locally, since ssh is not enabled, but cannot login on RPi because the password set during build from "make menuconfig" is not working. Have tried default password as mentioned in manual (linux123) is not working.
> 
> ----- Reply to message -----
> Subject: Re: [openadk] Root password problem
> Date: 4 July 2017 at 09:44:32
> From: Waldemar Brodkorb <wbx at openadk.org> <mailto:wbx at openadk.org>
> To: G Z <gtfo at inbox.eu> <mailto:gtfo at inbox.eu>
> Hi,
> 
> after you have changed the password directly on the rpi, did you saved the changes with 'cfgfs commit'?
> 
> Do you have read the manual about cfgfs?
> 
> The password in .config is hashed with mkcrypt?
> Does the login works with the default password?
> 
> Are you trying to login via ssh or locally with a keyboard?
> 
> best regards
> Waldemar
> 
> > Am 04.07.2017 um 08:37 schrieb G Z <gtfo at inbox.eu>:
> >
> > Hello,
> > I was building default image for vanilla raspberry pi and have changed root password, however after successful build and booting up, I can't login. I've also tried to create user with some password, but all fails. I've checked password in .config and it matches the one I've set from menuconfig. Have tried both git://openadk.org/git/openadk and snapshots.
> >
> >
> > _______________________________________________
> > dev mailing list
> > dev at openadk.org
> > https://mailman.openadk.org/cgi-bin/mailman/listinfo/dev <https://mailman.openadk.org/cgi-bin/mailman/listinfo/dev>
> 
> 
> _______________________________________________
> dev mailing list
> dev at openadk.org
> https://mailman.openadk.org/cgi-bin/mailman/listinfo/dev

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.openadk.org/pipermail/dev/attachments/20170704/7b61f2d4/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 496 bytes
Desc: Message signed with OpenPGP
URL: <http://mailman.openadk.org/pipermail/dev/attachments/20170704/7b61f2d4/attachment.sig>


More information about the dev mailing list